Option for advance search, regex, boolean?

As our blogs become a centerpiece of our lives, where we store pictures, articles we read, locations, and much more, there’s a use case for more advanced search.

Currently, the search option (under Posts) doesn’t seem to support anything beyond a simple keyword search. Is it possible to add a boolean option so we can, for example, search for “coffee AND trip” or similar? A plugin, perhaps?

Plug-ins can’t add functionality to the Micro.blog admin interface, like you’re describing here. But it’s possible to write search plug-ins that show up on your actual blog.

My plug-in, Search Space, doesn’t have support for regex or boolean searches, but it does use another algorithm for finding results. It could be worth checking out; you might like it better than the built-in search.

Also, most search engines, like DuckDuckGo, let you search a specific website using syntax like site:https://taonaw.com coffee trip.

Nice useful plug-in! It doesn’t do what I need 100%, but it definitely helps - and I like the idea other people can search with it too.

You have a point about using search engines, ever since I started archiving my blog with the internet archive this should work as well, I shall try.

How can I include this search in my navigation on the blog? When I add it as a page (I made sure the box to include it as part of the navigation was checked), it doesn’t show up. I also changed the path to be /search-space instead of just /, which is what it does by default.

To add any URL to the navigation, create a new page and paste the URL in the page’s content. So, in this case: https://taonaw.com/search-space/. More info is over here.

Yes, that’s exactly what I did, as I did before with my other pages.

So I went ahead and tried this on my test blog; after I installed the plug-in and tried to create the page, instead of having a / as the path on the test blog, it created /search. I tried that on my main blog, and it worked - the link shows. So / doesn’t work, and /search-space/ doesn’t work. I’m not sure why, it is probably something I changed in the theme.

Okay, you might have stumbled upon an edge case we’ve observed before where one can end up in an infinite redirect loop.