I broke my federation

So, I changed my username under accounts.

That seems to have broken my federation.

I reset my fediverse name to use drose@micro.blog (switched account name from danielmrose to drose) to try and get more compatibility across the fediverse landscape.

I have now disappeared from the fediverse.

I can cross post just fine.

But, if I reply from micro blog to a mastodon user it doesn’t show up and if you search for my handle it doesn’t exist, even when seeking to follow from the micro.blog/drose page in the follow form it returns a “user does not exist” error.

Any help would be appreciated.

I have the exact same problem!

I’m fairly certain it worked previously, but I can’t find myself anymore. Here’s what I’ve done:

  • Resetting, and adding the Fediverse username again.
  • Found my own Mastodon account, and followed and commented. (I could see no trace of either.)
  • Searched for both the username I’ve set: @micro@havn.blog, and my default username: @erlend@micro.blog.

I can’t find you either - but it’s good to know that I’m not alone! :smiling_face:

I can find some other micro.blog users through Mastodon, though - but might still be a bug here.

I’m glad I’m not the only one. I tend to break things. :joy:

@Havn — I checked @micro@havn.blog from Mastodon and I’m seeing it. Maybe there was a caching delay or something? Is it showing up for you now?

@danielmrose — After you changed your Micro.blog username, did you go into Account → View Fediverse Details and “Reset” your username there? Unfortunately that is required when a username or domain name changes. There is no seamless way to migrate between usernames, so the fediverse side has to be reset separately, which removes all your existing followers.

I did. I reset it drose@micro.blog and now this is what happens when I try the “follow from” on micro.blog/drose:

I still can’t find it (I’m on mas.to, btw), and I’ve asked others to try and they don’t find it either.

And interestingly, I just got a private mention from a mutual on Mastodon who has the same problem! (And I can’t find him either, even though he has a standard micro.blog username. And I can find some micro.blog users.)

Edit: I can’t find @danielmrose either.

I’m trying to figure out what’s going on here. I see @micro@havn.blog from indieweb.social but not from mastodon.social, so something is definitely wrong. Do you mind if I reset your fediverse username again (to the same thing) while testing this?

Yes, do whatever you want!

You can also contact me at @havn@mas.to if need anything from me. :slightly_smiling_face:

I’ll also pay attention to this thread. :+1:t2:

Feel free to reset mine as needed as well. Do whatever you need.

Same problem here, though I have not changed my username (I just signed up to Micro.blog yesterday so everything on my blog is completely vanilla). Can not find my micro.blog-user through Mastodon.


Did you find anything here, @manton?

I’m still not properly federated, so that makes Micro.blog much less useful, as most of the people I follow aren’t on the service, so I can’t reply to them!

I’m still testing this. I think something may have changed on the Mastodon side with verifying URLs, because I can’t see anything wrong in Micro.blog and nothing related to this has changed recently. As soon as I can confirm what changed, I will work around it. It’s my top priority to solve today.

1 Like

Fixed! It was indeed Mastodon being a little more picky than it used to be about the responses from Micro.blog. I can follow these accounts now in my testing.


Yes yes! Looks like it’s all back and running.

I still kind find myself… :pensive:

Do you think it should just take some time?

(@micro@havn.blog from mas.to)

I have a feeling that it’s a caching issue on each Mastodon server that will resolve after some kind of delay. I can find @micro@havn.blog from indieweb.social, but not yet from mastodon.social. I also tried to reset your profile again, but that didn’t change anything.

Let’s give it a few hours and if it’s still not working, let me know.


Will do!
It’s bed time here in Norway - so I’ll report back in the morning (when you’re probably sleeping :smiling_face:).

Still nothing. :confused:

Hi there! I am also having the same problem. I am on mastodon.social right now. And if I search for @alex@alexanderbellgram.com (my Fediverse username in Micro.blog account settings), it doesn’t show up. I think this might be related to my separate help post where my reply to a Mastondon account within Micro.blog does not appear on Mastodon.social (probably because my fediverse user account doesn’t show up either).

1 Like

Just reset my Fediverse username in account settings. It’s taking awhile, which is weird because I have no followers on Mastodon. Stand by…