Deleted post stuck

I’ve been playing with importing my old posts to the with various methods. Then I found that that post

deleted from my posts but remains on the hosted blog, and on my @lc feed. Deleting it on the timeline results in temporary disappearance from the list of the messages but it returns after the page is refreshed! How do I work with that and is there a way to weave such bugs on the user end?

If you want to delete the actual blog post, search for it on the Posts page and tap Delete.

Thank you, @sod ! But I’m behind the basic use, please consider the “bug” part of my request, the linked post is no longer on my “Post page” so there is no way to tap a Delete. But it is still listed on the hosted microblog and on the timeline. There is the “remove” link on the timeline I can tap, but the post returns to the timeline after page refresh.

Maybe it’s something similar to this? Ghost posts keep reappearing I deleted my entire blog (literally, by clicking the trash icon next to the blog name) and created a new one. Old posts keep coming back. It’s frustrating.

looks like it, @otaviocc ! I didn’t delete the blog, but couple of similar posts, trying to back-date them… @manton would you please take a look at these two?

Have you tried doing a full rebuild of your blog? Go to the logs page and hit the Rebuild button.

If you’re asking me, of course. And posting something or changing a page, or editing a tag brings them all back. This is caching, not user error.

Sorry, my reply was meant for @lc.

Awesome, that worked! Thanks, @sod , I didn’t know this rebuild option existed!