Cross-posting doesn't work, nor options

Not sure what happened, but a few days ago, the cross-posting from my to Mastodon just stopped working completely.

Also, the options don’t appear anymore. I can click the wheel and see the line to see cross-posting options, but when I click it, nothing happens. This is true on all my devices: iMac, iPhone, iPad, MacBook. I just post everything twice now, once to and once to Mastodon.

Working now! :slight_smile: Thanks to whomever fixed it!

Glad it’s working again! Not totally sure what happened or why it resolved itself, so let us know if it fails again.

Looks like it’s happening again. The post I made awhile ago still hasn’t shown up.

Also I still can’t see cross-posting options in the browser (I’ve tried Safari and Firefox) or the iPhone or iPad.

I checked the iPhone app, and interestingly that one says, “No cross-posting options to display”. But when I check Account settings, cross-posting to is set up and the option is to Disable (which means right now it’s running, right?). So I’m a bit confused?

I tried disabling the cross-posting to and then re-enabling it, but so far the test post isn’t publishing.

I’m also facing some issues with cross-posting (and some with scheduled posts) and created a new entry with details and steps to reproduce them. Not sure if the the root cause is the same, that’s why I created a new entry.