Bookmark RSS Feed Not Working

Speaking of RSS feed errors, I’ve been having trouble with my unique read later feed of bookmarks saved on It hasn’t pulled anything new in since March 13, which is probably the last time I tried unsubscribing and resubscribing to it.

I keep forgetting to revisit the sites I’ve saved since they’re not showing up in my feed reader!


Not something anything obviously wrong with your read later feed. The latest entry is from today. Does resubscribing actually get it to load again? That doesn’t make much sense, but I guess your feed reader could be confused and stop loading it. What feed reader are you using?

Yeah, resubscribing to it in Reeder this morning brought up the 40+ bookmarks I’d been missing. I’m using Reeder’s built-in subscription feature, which is iCloud on the backend. I’ll subscribe in Feedly too, just to see if it has the same issue there.

On a side note, is there supposed to be multiple entries per bookmarked item? I see sometimes one is the archived version, but it seems kind of inconsistent and not terribly helpful to have duplicates in the feed. Maybe I’m not understanding it fully.

Yeah, the duplicates are normal but I think we do need to change it. The idea was that one is the bookmark, and one is a text archive of the web page, if there is one. Perhaps we should just combine them into a single item in the feed.

That sounds way more ideal. A little spot for source/archive links.

Update: I actually can’t seem to subscribe with Feedly. Errors in Reeder and their web app can’t see/find the feed.

I won’t help you, @jarrod, but I tried subscribing to my own bookmarks JSON feed in Reeder 4 and NetNewsWire just now, and it worked fine in both apps. So something might be up with your specific feed.

You could try validating the JSON data of your feed to make sure everything is at least technically alright there.

Do you use Feedly too? Would you mind testing my feed to see if you’re able to subscribe?

No, I’m not using Feedly unfortunately, but your feed worked fine in NetNewsWire and Reeder 4. (The latest bookmark is about DropScout.)


I have a similar problem like @jarrod , I’ve tried to validate the JSON feed as suggested by @sod with and I got the following error:

I think you might have pasted the URL (address) of the feed and not its content.

:exploding_head: OMG, you were right! It’s validated.