Using to publish on

I just have tried to send a new post using The app gets mentioned correctly in my account settings. I do get the following error message. The post seems not to be transfered. Funny details: the image has been uploaded correctly!? Any idea what is going wrong there!? Thanks for your help.

Something went wrong!
Your Micropub endpoint indicated that something went wrong creating the post.

Micropub Response

Below is the response from your Micropub endpoint. This may contain helpful information that can be used to troubleshoot the issue.

HTTP/1.1 500 Internal Server Error
server: nginx/1.14.2
date: Tue, 01 Aug 2023 08:47:11 GMT
content-type: text/html;charset=utf-8
content-length: 526
access-control-allow-origin: *
access-control-allow-methods: POST, GET, OPTIONS, DELETE
access-control-allow-headers: Authorization, Origin, X-Requested-With, Content-Type, Accept
connection: close

Just to be clear, you’re trying to use, right? What kind of post are you creating? It seems to be working in my testing.

Right, I am trying to use Just two lines of text and one jpg-image and I do get the error message mentioned above!?

Weird. Seems to be working fine for me. Do you mind sharing a screenshot of what the post looks like in Quill before posting? Curious what the difference is. Thanks!

Just like that.

Anything you can see what is going wrong here!? When I do press “post” I do get the above mentioned error message. :confused:

Looks totally fine. Do you mind trying to post one more time and I can watch the server for related errors? Thanks!

Ok, I gave it another try. Post+photo via quill. Photo has been uploaded, post has not been published. Anything you can get from the server log!?

Thanks, that helps! I’ve tracked this down to something unexpected in the request when using an existing image and setting alt text. This seems like a bug in Quill, but I will work around it later today. In the meantime, if you upload a new photo and don’t set alt text, it should go through, and then you can set alt text manually in by editing the post.

Sorry, I was too quick to blame Quill. This was a bug in Fixed now.

Well done, @manton! Now it is up and running. Thanks a lot for investigating. Best regards, Suitbert