Twitter losing markdown

Cross-post to Twitter loses asterisks in the text. Is this expected or a bug? Is there an option to have the raw markdown post rather than the text extracted from the marked-up post?

Only @maton can answer this for sure, but I guess this is intended behavior.

The cross-posting function will post the content of your RSS feed to Twitter, and the RSS feed contains the rendered HTML, not your raw markdown. It looks like this:

<description>&lt;p&gt;elon: the sink is small and weird. you should be able to fix your sink the eay you want! 
&lt;em&gt;buys sink&lt;/em&gt;
&lt;img src=&#34;; width=&#34;600&#34; height=&#34;461&#34; alt=&#34;&#34; /&gt;

As Twitter has no support for HTML, it’s stripped away before cross-posting. There’s no simple option to get what you want, unfortunately. There are probably ways to hack around this, but if there’s enough demand, maybe @manton can add support instead?

1 Like

Thanks @sod, you’re right this is expected behavior. Because cross-posting can work with any feed (doesn’t even need to be hosted on, there’s usually just HTML and we don’t have a good way to reverse that to Markdown right now. It’s a cool idea that we can definitely consider, though!

Is it possible (with custom theme?) to produce an RSS feed that has the raw text, not converted to HTML? Then I could add that as what posts to Twitter?

Yes, it’s possible, but to use cross-posting, you will have to add that RSS feed to That will result in duplicate posts in your timeline, probably not what you want.

If you’re okay with markdown showing on Twitter’s and’s timelines, you could add your custom RSS feed and remove the default one.

Or you could use another service for the actual cross-posting, like Bridgy.

1 Like

I’m a-ok with markdown showing in the timeline. Twitter-like microblogging is (to me) just text. Tumblr-like microblogging straddles the line, but I would still say that text-is-text (to me). On the blog page, it makes much more sense to render it. I may go the custom-theme route and just change the regular RSS URL to not render the text.

IIRC, RSS may include multiple copies of the text? A summary and a full contents? (I guess this is out-of-scope for this forum!)

(I’m extremely unlikely to use anything like Bridgly or IFTTT.)

You’re probably thinking of description and the namespace extension to RSS, content:encoded. @manton prefers the former. :blush:

1 Like

You could certainly customize the RSS feed to use plain Markdown instead of HTML, and then that would be used when cross-posting. To do that, create an empty theme under Design → Edit Custom Themes, set it on your blog, and then click on the rss.xml template to make a copy of it for editing.

However, you would be optimizing for Twitter instead of your own blog. So, if someone subscribed to your microblog in their feed reader, they would see Markdown instead of styled text. I think one of the advantages of indie microblogging is that it embraces what the web is good at, like styled text and inline links. But it’s your blog so if you want to customize it this way, go for it! :slightly_smiling_face:

1 Like

I regret mentioning Twitter so many times! If I move my blog over here, I definitely agree. I’m looking to optimize my microblog. It’s just not the same as a blog! :stuck_out_tongue_winking_eye:

Yes, that’s exactly what I was confusing!

@sod i feel dumb for dismissing so quickly. I simply couldn’t imagine that the service only asks for the permissions it actually needs. Thanks for recommending it!! :heart:

1 Like

I (think) I have customized the rss.xml template…but it isn’t taking effect. Do I need to do something in addition to select the custom theme? Is there a full rebuild? Is there a build log if I screwed up the syntax or something?

You will find the log and ability to rebuild over at

1 Like

That page is on just-HTTP (not HTTPS) and does not redirect. @manton?

Alsö, the whole page refreshes every 5 seconds and even disabling JavaScript wouldn’t make it stop. I literally had to turn off my wifi so I could scroll. Wtf.

Ok, so the file isn’t named “rss.xml”. It’s named “index.xml” and there’s a “index.json” (that becomes “feed.json”) for some reason. Either way, got them fixed.