Trouble cloning theme again

For a while I’ve been working on a custom theme built on top of Tiny Theme. And the way I did it, was by forking the original repo, and then cloning that fork to

This worked fine. But when updating the theme with this button :point_up_2:t2: I only added new files from the repo - it won’t delete files that aren’t in the repo anymore. So after a while, my theme page would be really gunked up.

I had some troubles with getting a font file to load, so I thought the issue might be this - so I deleted my custom theme, and cloned it again. Looking back, I should’ve just kept the old and cloned as a separate theme - because here’s my problem: When cloning the theme again, doesn’t clone my repo properly anymore!

I’ve tested the exact same URL (GitHub - Erlendms/Tiny-Havn-theme: Adaptation of the Tiny theme for on my Mac, and it does work fine. The repo is also public, and it worked on previously.

Here’s what happens now:

Here’s the list I get when I clone:

So I get a few of my custom templates, and it catches the name “Tiny theme”. But there’s no microhooks, and not my current main.css, and a lot of other stuff is missing.

So, yeah - now my blog is kinda broken. :sweat_smile:


Edit: OK, now I moved out other repos within the repo - and then much more loaded. But still not everything. (Not .js files, for instance. Are these blocked? I thought I had them there and working previously…)

Uhm, OK. so I did two things, and it looks OK now. (Leaving this up in case someone else gets the same problem.)

  1. I think not having links (or whatever it’s called) to other repos helped.
  2. And just waiting a while helped as well!

Were you using submodules? I think that probably requires a whole different kind of fetching.

Uhm, no I don’t think so. I had “just” put my plugin repos inside my theme repo.