There is no cross-posting option on my second blog

If I go to “Accounts” then “Edit Sources and Cross-Posting,” I only see the setting for my first blog ( There’s no feed or cross-posting options for my second blog ( Is it supposed to be like this?

Yes, to have cross-posting options for the second blog, make sure to add the feed URL for the second blog in Edit Sources & Cross-posting. You should be able to add a feed with the URL “” and then it should start working. Each blog will have its own cross-posting settings.