Stuck posts?

I’m noticing that when I post a photo and text with MarsEdit, the post gets “stuck”. It shows up in my list of posts, but not on the timeline nor does it get crossposted. When I post a subsequent entry that’s just text (either using MarsEdit or the Micro Blog website) the stuck post appears in the other places as expected.

Is it a sign that the server is a bit overwhelmed at the moment, or is this a problem with how I have things configured?

I replied on the timeline but quoting myself here for reference.

Next time it happens, you could try forcing a complete rebuild of your site by hitting the button on the logs page. If that fixes the problem, @manton might have to look into why that is.

Maybe @danielpunkass has theories of what might be going on as well? (If it happens explicitly when you post from MarsEdit.)

Thanks - I’ll give that a try later this morning and let the appropriate person know.

I tried this again today and everything is working as expected. I’m guessing it was an overloaded server last week.

And it broke again. But it appears that the layout code that MarsEdit put in broke the post from publishing. When I edited the img tag code and took that out by hand, everything worked fine. I’ll let Daniel know.

+1 — I’ve run into this problem too.

Can you provide a snippet of the code in MarsEdit? Also, have you gone to Logs to see what errors may be occurring when building your blog?

Here’s an example of the sort of code MarsEdit is creating when I put a picture in a post:

img style="display: block; margin-left: auto; margin-right: auto;

It’s all legit code, but the post gets stuck unless I edit it out - then the post gets published immediately.

What do the logs say?

I finally got the error to happen again. There were no errors reported in the logs, but I did use the button to manually rebuild the blog and this is what the log output reported: (Maybe it had to do with missing folder?)

2022-11-18 15:51:21: Publish: Done :tada: — wnknisely

2022-11-18 15:51:20: Publish: Syncing files — wnknisely

2022-11-18 15:51:20: Publish: Got 8 uploads from storage to copy to blog

2022-11-18 15:51:19: Publish: Exporting media — wnknisely

2022-11-18 15:51:19: Publish: Running Hugo 0.91 — wnknisely

2022-11-18 15:51:19: Publish: Linking shared content files — wnknisely

2022-11-18 15:51:19: Publish: Adding replies — wnknisely

2022-11-18 15:51:19: Publish: Shared folder doesn’t exist, populating — wnknisely

2022-11-18 15:51:19: Publish: Preparing pages — wnknisely

2022-11-18 15:51:19: Publish: Publishing on server Broggie :steam_locomotive: — wnknisely

2022-11-18 15:51:19: Publish: Starting full rebuild…