Site Troubleshooting - Missing Navigation, Other Themes Won't Load, Etc

I’ve recently run into a number of visual site-breaking issues that I’d appreciate guidance on fixing.

Initially Manton had me re-install the Bookmarks Plug-In, which fixed my site from 404ing, but several issues persist:

  • I am not able to see the top navigation in the Paper theme (with a link back to the homepage, plus logo), and I’ve tried removing all custom CSS on/off to no avail
  • All posts seem to be jamming together now, with no delineation between them in the primary homepage view
  • Photos aren’t visible in the main scroll view of the site, either (you have to click through the permalink to see them)
  • Tried installing and using a different Theme for the site, to verify if it was Paper theme-related, but the site won’t load with other Themes at all.
  • I saw this post from a couple years ago, and tried the suggested action, but it did not fix the issue.

Is there any easy way to just wipe the site design/plug-ins clean (while keeping all the content, of course), and I could just start over with adding a theme, plug-ins, etc.?


Before doing anything too drastic, have you tried forcing a rebuild of the blog by hitting the button on this page? If not, do that and keep an eye on the logs. Often, they can provide a clue to what’s going on.

I haven’t looked closely at your site yet, but to reset everything you should be able to:

  • Remove all the plug-ins except the theme you want to use.
  • On the Design page, change the “Custom Theme” (if there is one) to None.
  • Also on the Design page, change the Hugo version to 0.91, the default.
  • If you have any custom CSS, save a copy somewhere and clear it out.

Appreciate both your help, @sod and @manton.

I followed your steps, and it looks like everything is mostly back to normal. Couple things:

  • I am still not seeing images appear in the homepage view alongside posts, nor am I seeing hyperlinks used in any kind of post (long or short), but perhaps this will remedy itself once I publish another post with an image. This may also be a result of the rebuild?
  • As strange as it sounds, it seems like the culprit was Tinylytics – I had been referencing the javascript in the Meta tags plug-in, but also had recently added the new Tinylytics Plug-in and perhaps the double-duty of having both was breaking the site. Keeping just one instance of this is the way to go (and probably seems obvious in retrospect).