Site archive not working

I’ve reported this to The archive of my site at Frankly... is not current and incomplete. I also observe that the One This Day “feature” or “plugin” has not been pulling posts later than last year.

re: On This Day, you can also ask Jonathan for help on or on the GitHub repo. I’ve yet to see on him on the forums.

A follow up note, I have been downloading the Wordpress export XML as a backup and while I see it contains all of my posts, I note that the HTML for the earliest ones no longer exist, for example:

I decided to change the theme of my site thinking that might force a regeneration. So far the appearnce of the archive page has not changed, but I assume it might take time. I do note the following error on the design page:

Theme error: Error building site: “/frankm_0a4b58/content/2019/05/19/”: failed to unmarshal YAML: yaml: line 6: did not find expected node content

1 Like

I can comfirm. The Archive system has bugs, as well as the filters.

Re the first, when I update old posts (by actually changing the contents, just hitting “update” does nothing), I can see posts appear on an archive page up to 27 posts or so, while more exist.

Re the latter, when I apply a filter, all posts are tagged (yay!), but only a few appear in the archive. I have to change each post and update it before it appears in my archive (and then only up to a point, see paragraph above).

My site is, a subdomain of

I didn’t get an @-back on M.b so have added issue on GH for my idea

My issue has been resolved. I had a post on 2019-05-19 that was causing an error, I went and deleted that post and forced updates to the Archive and Photos pages, along with creating a new post. After a brief period of time for the site to re-generate, all is well again.

1 Like

How did you know which post caused the error?

Manton told me, but there was an error on the Design page.

@manton Could you look at my Archive page too? It isn’t working properly for me either. I’m still seeing categories that are deleted. Highlighted in the screenshot.

A good place to check is in addition to the Design page. Most of the time build issues that persist on a complete build have to do with old posts or content failing to build while recent stuff that’s built first for speed is totally fine. This is especially true with a blog that had a large set of imports from another system.

Putting the error messages under Design kind of made sense when most of the errors were from custom themes, but since it can happen for other problems too I’m looking into how we can elevate the error to the home page or somewhere obvious.

My Archive page was stuck on the Tufte theme even after I removed it from my site. I’ve deleted the Archive page as a result.

As a test, I added the Archive page back, and it’s still adopting the Tufte theme…

Thanks to all those who have commented already above. I’ve also been trying to figure out why categories I’ve deleted are still showing up on my Archive page: Stephen Schenkenberg • Notes - Stephen Schenkenberg • Notes

Appreciate any advice that’s out there.

Have you tried navigating to AccountView logs and hitting the Rebuild button there? That forces a total rebuild of your blog and might solve the problem you’re describing.

@sod Thanks so much. That worked.