Root domain not verified

I have just noticed against the HTTPS status for my website is the message, “root domain not verified.” This is for a website for which https has been working since I registered the site with MB.

What would I need to do to remove this message? Is this help page relevant?


So the root domain (sometimes called the naked domain) is your domain without the www part (called a subdomain). In your case:

I glanced at the DNS records for your root domain, and it looks like it lacks the A record pointing to’s IP address. Probably this is what causes the error message you see.

Try following the instructions in Custom domains. Especially this part:

If you want to use a root domain such as, create an “A” record wherever your domain is registered and use the IP address value: “”.

Thank you.

I just went to check the DNS records in Hover where the domain is registered and the A record is set to the value that you mentioned. Could there be something else that I am doing, or not, that is causing the A record not to be noticed - I’m saying that based on what you said about the root domain lacking an A record?

Are you sure the A record is set on the root domain (not the www subdomain)? If so, you should probably contact Hover and ask them why that isn’t reflected in the publicly facing DNS servers.

I used Google’s Dig tool to test your root domain. This is the result for

Record not found! indicates the A record you see in the Hover interface isn’t reflected publicly.

I got the same result on my domain, so I changed the A record into what you said. A few minutes later I got an automated email from MB, stating " HTTPS now enabled for your blog."

I’ve been pulled away from this due to a family illness, and just getting back to it. I ended up deleting the A record and reentering it. I am still seeing the “root domain not verified” message. My question now is, what value do I enter for the Host setting within the A record? I set it to @. Is that correct?


Thank you for sharing your DNS settings @renevanbelzen. My A record is the same as yours. I have a CNAME record like yours with the Host field set to www, and another almost identical, except the Host is set to microblog. I cannot remember why, it was set a while back? HHmmmm…

While I am getting the “root domain not verified” message, the domain is still has HTTPS enabled. Maybe I should just leave it and chalk it up to an oddity?

Could you provide a screenshot?

Also, don’t forget to enter your domain name, as I did for mine in the Design tab of the web interface, and update the Design (button at the bottom of the page).

Looks like you or Hover fixed the problem. :blush: No more Record not found! in my end:

It seems okay now, at least from a DNS perspective. Do you still see the “root domain not verified” message, or has it gone away?

I can see you have two different blogs, so both of those records are needed. They are pointing and, respectively.