Posts not showing in timeline or Mastodon


As of today my posts stopped going to Mastodon. I am entering the posts on the website not through a client. I also noticed that none of my posts this afternoon made it to the timeline. If I don’t see them on the timeline I guess nobody else does either?

I do see those posts in the posts list, as well as on my hosted blog. So they are getting somewhere.

I don’t know if this would be related, but I have also been importing a few hundred posts from my old site.



1 Like

Hopefully, it’s a temporary glitch. You could try forcing a timeline refresh by going to the Feeds page and hitting the refresh button, looking like :arrows_counterclockwise:.

Keep an eye out for anything suspicious in the logs while doing this.

I tried the refresh button, but the log just indicated no changes.

Just tried a new post a minute ago. Not on Mastodon and not on the timeline.

2022-11-30 06:48:15: Publish: Done 🎉 — bnmnetp

2022-11-30 06:48:14: Publish: Syncing files — bnmnetp

2022-11-30 06:48:14: Publish: Running Hugo 0.54 — bnmnetp

2022-11-30 06:48:14: Publish: Linking shared content files — bnmnetp

2022-11-30 06:48:13: Publish: Already queued, scheduling +1 minutes — bnmnetp

2022-11-30 06:48:12: Publish: Shared folder exists, updating — bnmnetp

2022-11-30 06:48:12: Publish: Preparing pages — bnmnetp

2022-11-30 06:48:11: Publish: Publishing on server [Retlaw]( 🚂 — bnmnetp

My next step is to remove the mastondon link from my account and see what that does.

OK, I think I figured out the problem.

I changed my custom domain from to just But – I didn’t realize that I needed to update that url on the feeds page. - I did have an alias set up so that micro would still work. Once I changed the url on the feeds page then I saw the post I made a while ago show up on the timeline.

The log is now showing me errors related to bad tokens and a few clients I’ve been playing with. I guess I may need to refresh those?

Woohoo! :tada: I’m glad you solved it.

I see the bad token errors for my blog as well. It’s not something I’ve encountered before. Maybe @manton can tell us what that is about?

We’ve had some trouble updating the push notifications behind the scenes, because the certificates have to be updated once a year. Working on solving that. It won’t affect publishing your blog or sending replies, but does mean that in some cases someone you’re replying to might not get the push notification on all their devices.

Thanks @sod and @manton.

I don’t read documentation unless I’m really stuck :grimacing: so maybe this is covered, but it was definitely not obvious that by going from to the naked domain that I would need to do anything to my feeds, especially since I made a CNAME record for the micro. Which I thought would make micro and the naked domain essentially the same.

I’m guessing I’m in a small minority of people who mess with their domains but I was being cautious in my migration from a self hosted site to hosting.

Quite a lot of indieweb and other social protocols use domain as a major part of identify, so any domain change has consequences in terms of webmentions, etc.