Posts not federating?

unsure if this is the right place to ask: Is there anything worth knowing about federation from to “the fediverse” (Mastodon, Friendica instances)? I learnt that I can follow particular accounts from within and at least for some I am actually seeing posts in my timeline then and now. However, following anyone from any of my Mastodon, Friendica, Hubzilla accounts, I never managed to see any posts there. Seems they’re not federated at all. Is this a known issue? Anything to be done about that (or any way how to debug that)?
Thanks in advance and best regards,

Users have to turn on either crossposting or a Mastodon ID for their account (which was turned on by default some time ago). However, their addresses are not – they are often at their own domain. So while I cross post to there’s also a ActivityPub stream for my account. That ActivityPub stream is not it’s – from my own domain.

You can find your own stream on the Account Page under the ActivityPub section.

EDIT 2023-06-06: I just deleted the previous blog post and reposted it and the post appeared in my ActivityPub feed. I guess all is well for now.

I’m also not seeing my posts appear on Mastodon. More specifically, last night I put up a new blog post, but it didn’t appear in my account’s ActivityPub feed.

My ActivityPub compatible username is currently and I set up that up at least a week ago. When I search for that username on Mastodon I see that they have 0 posts when there should be at least the one from last night. It may also be worth noting that at the time I posted last night, I didn’t have any integrations enabled on the page; I added a few maybe an hour after posting.

Hmmm. I think I don’t really get it so far. :pensive: In my Account Page, ActivityPub section, I see as “Mastodon compatible user name”. Trying to follow this account from Friendica or Mastodon works - I see profile, profile picture, profile description and all. But I fail to see any posts. Fail on my side?
Edit: Same in example for - @jean - there’s advertised on the page as Mastodon compatible user name, which I can subscribe to and see the profile but again no posts…)

Maybe you’re the first one to follow your own and Jean’s accounts on those instances? Mastodon won’t fetch old posts and maybe Frendica works the same way?

Take my own AtivityPub account as an example. There are currently no posts showing on your instance ( because no one there follows my account yet. But they are showing up on and other instances.

Yes, that was my first idea as well, but in the meantime, I’ve been following both “my” and Jeans user on both my Friendica and my Mastodon instance for about a month, and still no data has been federated. That’s what leaves me a bit confused…

Okay, then it’s probably something @manton has to look into.

This feels very possibly like an instance issue. I am on I know at least some people have followed my stream because I’ve gotten comments that way. When I searched, I saw no posts because no one on followed me. I followed myself, made a post, and saw this immediately in Ivory:

Bottom is my cross post to, top is my ActivityPubStream from

Interesting. In your case, at least on Friendica, I see a stream of your posts coming from but none from Followed both accounts, just for the sake of it, will check back on that later. Pretty well could be so far no one on my instance is following

(Not sure if this is related, but it seems to be just like this the other way 'round too: I’m following several Fediverse people, including cough my own accounts, from and even while I apparently manage to follow them and to see their profile, I never happen to see any of their posts in my timeline. Is there a limit / definition on which instances does (not) federate with? Are some blocked?)

Have you been seeing my posts? I can confirm that they have come through consistent and instant now that I’m following my own ActivityPub Stream.

Keeping track of this, I see none of your posts coming from and a good deal of “content” coming from … happens on both Friendica and Mastodon. :no_mouth:

I see 100% of this content using, which strongly suggests to me that it’s an issue with your instance.

Hmm… odd. I’ve tested that on one Mastodon and two Friendica instances, and the behaviour for is consistently the same all over. So I’ll get in touch with the admin of my main instance to see whether we have any idea here. Still, a bit confused it happens on all of these… .

Adding to that, after subscribing to a few more accounts yesterday, it seems there are never attempts of trying to deliver messages to in example (which is where we tested and browsed the logs)… so most likely not an issue on the receiving side? Also, (re-)retrieving account data works well, and mentioning accounts seems, too.

My best bet is that however Friendica is doing ActivityStream subscription it’s inconsistent with the current spec or how Mastodon does it. Have you tried using a major mastodon instance known to be on the latest version?

I have exactly the same behaviour (no “incoming” post from, no “outgoing” posts in my timeline when following users on there) on which is a recent Mastodon instance. Will ask admins there; it seems they just don’t know of each others existence post-wise, even while I can subscribe to contacts vice versa…

(Adding to that: I noticed that apparently if people who subscribed my account mention me somewhere “else”, I don’t see these mentions on This is a bit inconvenient as it’s essentially lost communication…:pensive:)

Do you happen to have a link of one of the mentions that didn’t come through? That is supposed to work, and I do see Mastodon mentions pretty often.

Sure, please see [ˈloma] | Matthias ✔ @ [ˈloma] … most of this thread should have mentions of my in it. :slight_smile: