Posts failing to appear for hours?

I’ve noticed over the past couple of weeks that posts aren’t appearing, sometimes for days, though mostly just for hours. At first I thought it was because some of these were scheduled posts, but those are only sometimes affected.

The only thing that kind of seems to work is posting something new. That new thing may or may not appear for hours/days, but stuff that failed to post previously then shows up.

Rebuilding the blog doesn’t help. There are no errors mentioned in the log. It’ll even say something went through despite the fact that it appears nowhere.

Emptying my browser’s cache also fails to fix the problem. The things just aren’t posting when they’re supposed to, and on a consistently inconsistent basis.

1 Like

Sorry that this is failing so consistently for you. We sometimes see delays of minutes, but not all the time like that and not hours. On first glance, I didn’t see anything unusual about your account, but I’m taking another look at it.

If it helps, as of this writing there are three posts that supposedly have published, but don’t appear anywhere. Two have been in limbo for about three hours, while the other one was my attempt to goose those into appearing.

I really don’t know what to do on my end, because it doesn’t seem to matter if the post is set to publish immediately or is scheduled. Neither will appear, but other times they do. Replies seem to go out with zero problem.

Well, the problem continues. As of this morning, two scheduled posts and one real-time post hadn’t appeared in a twenty-four hour period. I wrote a new real-time post. It didn’t appear, either, but two of the missing ones did. Then I went back into the new post and edited it. That made it appear, but the third missing post still hasn’t shown up.

Everything worked fine until a couple of weeks ago, so clearly something has changed. The question is what.

Sam, if you don’t mind, can you send me a quick email to right after the next post to your blog? I’d like to watch this in real-time to troubleshoot. Thanks!

Another follow-up. A scheduled post failed to appear at 9:42am this morning. I’ve noticed that the only way to consistently get posts to appear is to edit them, at point they post. And you needn’t change anything in the “edit,” either. It doesn’t seem to care about that, only that you saved it again.

Latest follow-up. I watched a backlog of five scheduled posts refuse to appear before posting something in real-time to see if they’d pop up. They did, but the new entry didn’t! Not sure what that’s about. :man_shrugging:

For those keeping track at home, no scheduled posts of mine have appeared on in five days. I was going to wait for a week, but I think we have enough of a sample size to work with.

Looking at my posts section, it shows them as posted, but they don’t appear on my timeline or my site. I hate to keep harping on this, but something is clearly wrong because for hundreds of posts this feature worked fine until it suddenly didn’t.

I came here to post about them not showing up. I just signed up yesterday, and my micro blog doesn’t show up even after 24 hours. Not the best first impression but I hope there is some resolution soon.

Well, it’s February and this is still an issue. I had a scheduled post appear appropriately, but two follow-ups, submitted in real-time, that haven’t. I refuse to believe this is a problem specific to me. Someone else has to be having it, too.