Posts don't load without "www" at the beginning of the address

I recently added my own domain to web hosting and noticed that when I try to access my posts without adding the “www.” at the beginning of the address, the posts are not loaded. When I use “www”, it works correctly.

Here’s an example:

This behavior also applies to pages on my site.

Could anyone tell me if there is any way to make the addresses work both ways?

Thanks in advance. will usually automatically redirect the version without “www”. I think there may be an issue with the DNS configuration here. Do you mind posting a screenshot of your DNS settings, or describe how it’s configured? Most importantly, there should only be one “A” record for the root domain

I forgot to mention that I requested the transfer of my domain to The transfer status is “Starting transfer”. So I don’t know if the old DNS still points to Anyway, here are the DNS settings before domain migration. Thank you for your help, @manton .

Hello, @manton . I still can’t access my website without the “www” at the address. Do you know what might be happening?

Judging by the screenshot, it looks like the ip address is wrong. It should be according to the page Custom domain names.

That was exactly it, @sod. It’s working properly now. Thank you very much!

Glad it’s working, thanks! Domain transfer are still a little finicky. I’ve added some extra checks on the side so that if things aren’t configured, it should give you a one-click options to configure the DNS records. When the transfer completes, check out to confirm everything.