Post not appearing on blog


I made a post today that does appear on my timeline but it doesn’t appear on my actual blog (hosted by even more than an hour later. I tried some of the solutions I saw mentioned here - full rebuild site and editing the post - but it still won’t show up on my blog!

I did notice my log says “Publish: Starting full rebuild…” but nothing further. I have a feeling that it used to display more information as to what phase it got to, so maybe my rebuild has somehow got stuck but without generating an error message…any help appreciated!


I’m experiencing the same, rebuilds get stuck. So something is probably up that @manton needs to look into.

1 Like

Something appears to be stalling in this morning - I’ve seen no new posts in my timeline since about 9am BST and my posts haven’t been published to my blog or added to the timeline feed.

Same with me. Stuck rebuild and post showing up on timeline but not on blog.

Same. Posts not showing on timeline since 9AM LIS, my own posts are not being published on the blog.

Same for me, I thought I’d made a theme change wrong and have been trying for some time to rectify.

Just thought I’d check help on the off chance! Could do with a status page for these types of things.

Something is definitely afoot. My last post this morning never made it to my website & Cross posting to mastodon is not working (or severely lagged) and I’ve got a photo that refuses to load at The photo also didn’t post to mastodon though the text did. So I tried turning off the CDN but no dice.

+1 here too. First post today got published on blog, two others not. Mastodon cross-posting did not go through for any.

Something’s stuck, obviously :sweat_smile:

The same. The last update to my timeline (so of those that I follow) was at 8:40am Western European Time.

Yes. Also got a missing photo on a blog, not sure if I’ll have to delete and upload again, or if it will just start working once the issues are solved. often has these sorts of problems outside of US working hours. Hopefully one day the team can expand to better cover everybody’s needs.

1 Like

I’ve tried to delete, reupload, and relink a photo but no dice.

Sorry everyone! This is now fixed. Just posted an update to @news, and everything should catch up so nothing was missed.

Yes :pensive:

Posts are showing up on the blog, but got crossposted without photos.

Thank you :pray:t2:

Wonderful, thanks, mine all looks good now.

I still see issues on delays. Like HOURS and on a couple of occasions not at all. Nothing has changed in my blog set up. Only posting this now - because I see others with a related issue. For me - problem has definitely not gone away. Not got use case that is repeatable though.

I’ll also chime in that this seems to be affecting me quite often in the last few days. I have to go back and edit the post to trigger it appearing in the timeline.

I have the same problem, the posts to my blog are pending. :thinking:

For example I have posted this message and it correctly results in the Timeline while it seems to be somehow delayed to appear to the blog.

  • Here the post that correctly appears in the timeline:

  • And here below the pending post:

Immagine 2023-05-21 132501