Not all tweets imported

Hello - I downloaded my twitter archive and uploaded it a couple days ago. I have tweets back to 2007 and can see those in data/tweets.js in the downloaded zip that I uploaded to m.b, but Tweets | Hello! from Rick Cogley has only a couple years available in the year picker.

If this is not by design, can someone kindly comment?

Are all tweets present if you look in the web interface by navigating to Posts and selecting in the dropdown menu at the top?

If so, you could try rebuilding the site by hitting the Rebuild button on this page and keeping an eye out for error messages in the logs showing there.

1 Like

hi @sod, thanks. All tweets were not present in the list under posts. I tried rebuilding anyway, and there were no errors in the log on rebuild, but, still no additional tweets before 2021.

Okay, then we’ve ruled out a build problem with the blog, at least. So, for one reason or another, something goes wrong during import.

I’m not sure, but I think the import function writes to the logs. You could try starting a new import and watching for errors in the logs while it’s running.

1 Like

Thanks again. Yes, it does, but it’s hard to capture anything specific in there, because the UI is a bit “skittish”. When I search tweet, I can find the general area of the log where the upload occurred, but I can’t get it to stay put for a minute to allow me to copy paste it to a gist. What I can say is, there are no apparent errors but the import just seems to stop at some point in 2021.

I had hoped for some kind of indication there. Thanks for trying! I’m afraid that @manton has to take a closer look then.

1 Like

appreciate your trying and any followup @manton can provide later

For large tweet archives, sometimes the import just fails halfway through. The only solution is to import again. And if the tweets are still not all there, import again until it’s complete. Sorry, I wish I knew why this happens.

The good news is it’s smart enough not to try to import all your photos from Twitter again, so it should be much faster on subsequent imports.

1 Like

thanks, I’ll try it again!

Progress report: It’s still grinding away, but some more years have been uploaded. I’ll keep repeating until it’s done.

It does a couple years every time I re-upload. Slowly but surely, slowly but surely.

My tweet archive has failed to upload three times. No tweets show. Zip is largish… try again? I get progress br but it sits there 5% done or so forever but never… the tweets page is established but no content.

Also import of Wordpress export archive in xml fails, gives no indication of my posts imported. My Wordpress is way smaller than twitter archive.

Hi, want to ask, when I import the archives completed, how long should I wait? I already waited two hours after imported. Thanks.

It shouldn’t take that long. After the import finishes, can you see the tweets blog if you click on Posts → “…” menu? Also check Account → View logs. That’s where it will report on the progress if there is a lot of work to do in the background, such as copying photos used in tweets.

Hi, thanks for your reply.

I fixed the issue, it’s my fault, I upload the wrong blog, I should upload the zip to, sorry…