Need Help with Custom Domain Setup

Hello Community,

I’ve been trying to set up my custom domain with but have run into some persistent issues.
My site worked perfectly fine when hosted on the subdomain. However, after switching to my custom domain (, I’m facing a site timeout – the site isn’t loading as it should.


14 ( 102.377 ms 99.950 ms 99.653 ms
15 ( 132.764 ms 130.135 ms 128.432 ms
16 * * *
17 * * *
18 * * *

The only error message I see in logs is ‘Feed: Unknown exception OpenSSL::SSL::SSLError’. This issue seems to have arisen after the transition to the custom domain.

Here’s what I’ve done so far:

  • Checked DNS settings for accuracy.
  • Reached out to my domain provider for potential adjustments.
  • Ensured that no additional domain options like DNSSEC and Anycast are interfering.

Despite these steps, the timeout and SSL error persist, and I’m at a bit of a loss on how to proceed further.

I’m not sure what else to check or try, and I would greatly appreciate any guidance, suggestions, or shared experiences that might help me get past this hurdle.

Thank you in advance for your time and assistance! :slight_smile:

Just checking, did you add the custom domain to the Domain name: field on the Design page?

Hi Matthew,

Yes, I did add my custom domain to the ‘Domain name’ field on the Design page. Additionally, I’ve tried re-entering the original domain (which worked fine) and then switching back to my custom domain ( by regenerating the pages, but unfortunately, this didn’t resolve the issue.

It really seems like something is still wrong with the DNS settings, or the old values are being cached for too long. When I try to load the domain name in Firefox, it times out. When I try in Safari, it loads a generic Nginx server page. Our servers for hosting blogs do not run Nginx.

I’m sorry to ask you to double-check the DNS records one more time, but are you completely sure there aren’t any old DNS records or duplicate values in there? I would also be curious what the TTL caching value is in case that is interfering with the correct settings propagating across the internet.

1 Like

It’s possible that some old values are indeed still being cached somewhere.
When I decided to try using a custom domain for, I took the opportunity to also switch my NS provider. Previously, my site was managed by the DNS (tizoo), but for the past two weeks, it’s been managed by Infomaniak. Looking at the DNS propagation results, this NS change seems to have been properly accounted for, but it’s possible that some records might still be cached in certain more static systems.

The current TTL is 3600.

; Actual version

$TTL 3600
@ IN SOA (2024012802 10800 3600 605800 3600)
3600 IN A
3600 IN AAAA 2600:3c00:1::68c8:16d7

Could it be that uses a more static repository of DNS records?

After conducting some tests with my domain and its subdomains, I’ve come to the conclusion that the time-out I was experiencing is likely due to the verification routine for SSL certificate creation at Let’s Encrypt, which I had also used with my domain previously.
Consequently, I’ve switched to using a domain I had almost forgotten I owned, which has a .zip extension. :slight_smile: This works well. It’s a symbolic change, but a welcome one nonetheless.

Thank you all for your assistance.