Modifying theme to adjust syntax highlighting

I am wondering what steps to take to change the syntax highlighting on an (as yet) unmodified version of the Tufte theme. I have two, somewhat independent, questions.

First question:

As far as I can tell, the Tufte theme has one configuration file, which does not mention markup or highlight, so I assume it is using the default, monokai. Indeed, if I use code fencing and name golang as the language, I get highlighting that matches the Chroma style gallery’s sample:

However, if I use elixir for highlighting, I get something awful:

The latter’s use of different sized characters for different syntactic elements is, in my opinion, awful – it emphasizes the UNIMPORTANT while making more important things (function names, variable names) fade into the background.

So my thought was that this font-fiddling is a property of the elixir (and ruby and c) code-fence name (but not of golang). However, when I try it at the Chroma playground, I get something with uniform sizes:

So: what’s responsible for the language-specific font-size fiddling and what do I do to turn it off?

Second question

If I want to fiddle with the Tufte theme’s config.json to override the syntax highlighter, do I need to make my own copy of the github repo, as is shown in the help video? That is: do I have to make an entire new custom theme based on the Tufte theme? Or is there a simpler way? From the plugins page, or the page specific to the Tufte theme, I don’t see any way to access my current theme files.

If you click here, you’ll be able to select the Tufte theme (or plug in, can’t remember which) and write your own stuff on top of that theme without a GitHub repo.

Here are some settings I use for syntax highlighting:

"markup": {
    "highlight": {
      "anchorLineNos": false,
      "codeFences": true,
      "guessSyntax": true,
      "hl_Lines": "",
      "lineAnchors": "",
      "lineNoStart": 1,
      "lineNos": true,
      "lineNumbersInTable": true,
      "noClasses": true,
      "style": "dracula",
      "tabWidth": 4
    "goldmark": {
      "renderer": {
        "unsafe": true

(note, that’s not valid because it’s not valid json because it’s a snippet of my configs).

I also don’t use the Tufte theme.