Is Archiving to Git Still Working?

I’ve just noticed that my git archive hasn’t been updated in a long time.

It’s not a big deal, but I’m wondering if it is still an active feature - or if I perhaps broke something along the way.

Mine updated 17 hours ago but it sent out like a 100 commits and only a few have actual content in them.

FWIW: It will apparently also not show anything, if nothing has changed since the last time it ran.

Mine never worked since I started microblogging

I’m also seeing not seeing any posts archived to Github. Admittedly I was late in the game setting it up, like 3 years(!), but still nothing there.

I hadn’t had anything pushed for the last 2 months (despite a couple of posts in that time). I noticed that updating my settings (I turned on the Internet Archive option) triggered a push and now it’s up to date, but I haven’t tried adding a new post and waiting for the next scheduled push.

Mine only shows a few uploaded files. Is there no resolution to this? @manton

I’m not aware of any bugs with GitHub archiving, although I know “it works for me” isn’t a very helpful reply… :slightly_smiling_face: If it’s been a while, I suggest clearing the GitHub username/repository and signing in again, to make sure that Micro.blog has the right credentials.

I’ll work on adding some better error messages when things go wrong. I’m also going to bump up how often it pushes changes to GitHub from once a week to maybe a few days, so that it’s faster to see changes.

1 Like