Images not displayed, seem to be a CDN problem although I'm not using the CDN option

I was going to post a link to this entry https://micro.mostrom.eu/2008/11/23/glaskroppsavlossning-r-ingen.html when I noticed that none of the photos were displayed. This was a bit odd and I looked at the english version of the same post https://micro.mostrom.eu/2008/11/23/losing-my-eye.html and one image was displayed (now when I looked again all of them are displayed :person_shrugging:t2:).

Anyway, I started to dig deeper into this and looked at the links in the page source they are all in the form https://micro.mostrom.eu/uploads/2023/c7a34c48d1.jpg. If I try a link in that form the image isn’t displayed.

So looking at the page https://micro.mostrom.eu/2008/11/23/glaskroppsavlossning-r-ingen.html using Safari’s view source page I started to command-click on the various photo links and discovered that clicking

https://micro.mostrom.eu/uploads/2023/c7a34c48d1.jpg

resulted in a new page that displayed a photo at the URL

https://cdn.uploads.micro.blog/130/2023/c7a34c48d1.jpg

Note that I have the CDN option turned off, I tried it long ago but turned it off because of some problems. So, I tried a URL of the other photos

https://micro.mostrom.eu/uploads/2023/b487f5f6d1.jpg

and nothing is displayed. However, if I manually change this to

https://cdn.uploads.micro.blog/130/2023/b487f5f6d1.jpg

then it’s displayed. To me, it looks like there are some issues with the CDN option and how it works.

My question: how can I fix this so the photos are displayed? I’ve only checked these two posts but I assume that I have more with the same problem.

Came here to see if anyone else had problems with their photos. I’m not sure if I’m experiencing the same problem as you, but all of the links on 📷 Photos | ConatusPrinciple are broken. I haven’t done anything to my blog as of recent, just posted stuff. I get this error message in the logs:

2024-05-15 23:25:31	Error: Error building site: failed to render pages: render of "page" failed: execute of template failed: template: post/single.html:70:3: executing "main" at <partial "microhook-after-comments.html" .>: error calling partial: execute of template failed: template: partials/microhook-after-comments.html:1:3: executing "partials/microhook-after-comments.html" at <partial "related-content.html" .>: error calling partial: "layouts/partials/related-content.html:8:16": execute of template failed: template: partials/related-content.html:8:16: executing "partials/related-content.html" at <.HeadingsFiltered>: can't evaluate field HeadingsFiltered in type page.Page

Me too, but after I re-enabled the CDN, all the images showed up!

1 Like

I had a similar issue with a post recently where I had non-CDN images that would load on inspect element but not in the page. I am using the CDN though, and I replaced all the links with the CDN version and it worked. @manton was looking into it.

Just to aid in troubleshooting, @manton, I have the same problem on my blog. Some images return 404 on first visit. But forcing a refresh will result in the images appearing. Some notes:

  • I have CDN disabled (and want it that way).
  • I tried temporarily enabling CDN and the problem went away. As soon as I disabled CDN again, the problem came back.
  • Fetching an image, like https://dahlstrand.net/uploads/2024/reffen.jpg, with curl results in a 302 redirect to https://cdn.uploads.micro.blog/58102/2024/reffen.jpg.

My blog also continues to have the same problem of my images sporadically not loading images. The photos are at random as well. It’s not always the same photos. I have CDN disabled.

Is anything being done to address this intermittent issue? I’ve wary of fully going all in with turning my Mb into a photo blog due to this issue.