I have ActivityPub turned off and forwarded but it’s still posting

In my account settings I turned off and forwarded ActivityPub subscribers to my other Mastodon account.

But, it seems to be still posting. Can this get turned off please.

If everything has been migrated successfully, you can delete the ActivityPub part of your profile by going to Account → View Fediverse Details → Reset.

I’m not sure what the default behavior should be after migrating. Perhaps not let anyone follow the account, which is what I think Mastodon does.

There is no reset.

Ah, you’re right… When it’s set to move, there’s no reset.

Let’s step back a little: how do you want it to work? After setting an account to migrate to a separate account on Mastodon, do you expect people to not be able to see your old profile at all, or not be allowed to follow it, or something else?

The big thing I need it to do is to stop posting.

And yes, people shouldn’t be allowed to follow it.

Here’s my old account at SocialCoop on Mastodon https://social.coop/@bmann

  • Message at top of what my new account is (replaces follow button with link to new profile)
  • grayed out profile / header

Should I cancel move and reset? I don’t want it posting any more.

Yes, if everything looks good with migrated followers, I would cancel the move and reset the fediverse profile in Micro.blog. You can then migrate again just to make sure Micro.blog shows the new Mastodon link.

OK. I’ve now got this screen to “set a username”. I’m just not going to set one, because I don’t want Mb to post to AP from my blog.