How to uninstall a plug-in

seems broken, I think it is because I installed a plug-in, get this message:

Theme error: “/billbennett_3c4ece/layouts/_default/baseof.html:10:1”: parse master failed: template: _default/list.archivehtml.html:10: unexpected unclosed action in command

How do I uninstall the plug-in? Will that fix the problem?

:wave: Hey @billbennettnz,

Uninstalling the plug-in and rebuilding the site will eliminate the problem – if the plug-in is at fault.

What plug-in did you install, and what theme are you using?

The plug-in is Pure by @ChrisHannah.

There is no option to remove it, hence my original question.

I think the Pure theme needs you to be on the latest version of Hugo (the blog engine that powers to work correctly.

Navigate to Design and change Hugo version to 0.91. Then hit Update Blog Settings.

And to answer your other question, how to uninstall the plug-in:

Navigate to Plug-ins and make sure the correct site is selected at the top (if you have more than one site on Next, look up the Pure plug-in in the list and tap Uninstall. This will change the current theme to Blank, so you will probably want to choose another theme after uninstalling Pure.

The Hugo update fixed it. Thanks.

But I still don’t see an uninstall button.

Weird, it’s there for me. Maybe it’s a bug? Or maybe your browser window is too small (like on a smartphone), so you need to scroll sideways to see the button? doesn’t show the Uninstall button if there’s only 1 theme plug-in installed. As a work-around, just install the “Default theme” plug-in and the old plug-in will be automatically disabled.

Ah, that makes sense; I had another theme installed when I tried Pure. Thanks for clarifying, @manton.

I have the same problem. When I signed up I had a very clean, minimalist beautiful theme. Then I installed a plugin and since then it’s a total mess. I can’t go back to the original theme. What is the name of the original theme? it sure is not “Default theme”, because “Default theme” looks very different from the original.

UPDATE: Found it! The default theme is “Marfa theme” by @manton