FeedLand rss

I’ve been testing Dave Winer’s feedLand.org site which is a rss gather & reader. Dave has now added the ability to create a RSS feed of you own wee posts.

I did this and added the feed to my settings.

I added a post which didn’t show up. So I ran this
curl https://micro.blog/ping -d url= http://data.feedland.org/feeds/johnjohnston.xml
in the terminal

I got this back:
405 Method Not Allowed

Code: MethodNotAllowed
Message: The specified method is not allowed against this resource.
Method: POST
ResourceType: OBJECT
RequestId: 11S6H37P7KG19VAQ
HostId: MSsUO+uJ7gi9JU4X5Rg2a6Kg9sgfDIEB4HDfouvCBqbWa3yG3H7Oz5r8JE3eqp8QcytdAPLKl8Q=

When I run this using my WordPress blog I get nothing back but micro.blog seems to check my feed and post anything new. (I do not usually do that 'cause WordPress pings micro.blog for me)

Any ideas?



A space has snuck between url= and http://data.feedland[…], so the curl command makes two requests. One to micro.blog and one to data.feedland.org. The latter does not allow POST requests and throws the 405 error.

Remove the space, and you should be all good.

curl https://micro.blog/ping -d url=http://data.feedland.org/feeds/johnjohnston.xml

Hi Sod,
Thanks. That works. Thanks too for the explanation.

Just for anyone else
Turns out it FeedLand RSS wasn’t working earlier, even if my command had been right, due to link elements not being in FeedLand rss.
Dave Winer has now changed that and as both micro.blog and FeedLand supports rssCloud I don’t need the ping.