Feed and cross posting issues

I just added a second feed to cross post from. It seemed to be “stuck” yesterday so I went in and refreshed it to fetch new posts as I saw recommended here.

All the posts cross posted to BlueSky without rich text inline links.

Example: https://bsky.app/profile/bmannconsulting.com/post/3kiceqnhl7k2x

On Microblog:

It did truncate and post a link back to my original for the one post that was over character limit, but no inline links posted.

On Mastodon, some characters were stripped, eg opening “ which usually replaces block quotes (but the trailing one was there)

Example: https://toolsforthought.social/@boris/111708038599989788

That feels like an off by one error.

Today, I add a single new post to test, waited an hour, and then went in and refreshed the feed.

Both Bluesky and Mastodon didn’t include links this time:

Mastodon: https://toolsforthought.social/@boris/111710427204647208 (I edited to add the link myself — I know only single first link is included and that’s fine)

Bluesky: https://bsky.app/profile/bmannconsulting.com/post/3kidgovbuu22m

My feed validates: http://validator.w3.org/check.cgi?url=https%3A//bmannconsulting.com/journal.xml

Please let me know when this is working again.

Yep. Definitely no links coming through to Bluesky as of today

Still some inconsistencies in Mastodon cross posted links. Specifically, the first link that isn’t a link to something else on my own site is what gets posted.

I wrote my posts expecting whatever the first link is to be posted as per

When I start a post with a block quote, the cross post definitely eats the opening “

I think there are a couple of things going on here. I checked your feed and noticed that the links are relative to your site instead of starting with “https://”… I have a feeling that is what is causing the problem. Is it possible to change them to be full URLs?

Yes, I can update my feed to make them full links (works fine in RSS readers and feed is valid). Please update the documentation to indicate that this is required for cross posting.

Doesn’t explain Bluesky (where no links, including full links to external things) are getting through.

In the screenshot for Bluesky, Linux Desktop and the Ethan Mollick post were direct offsite links. And same with my original screenshot, UniFi Dream Router is an offsite link.

Bluesky still broken

Posted with full links on Micro.blog timeline.

all off my cross posting stopped around 27th December - I have reported to help and mentioned on the stream - I changed nothing settings are as they should be and nothing - just stopped - @devilgate has seen thr same.

@JohnPhilpin I’ve gone in and hit the refresh button next to my feed, and that gets things going again. Have you tried that?

1 Like


I refreshed the top - is there anywhere else?

Nope. You can also check logs. It’s at the very bottom of the accounts screen.

My logs have mostly been good despite not posting correctly to Bluesky.

@JohnPhilpin Just fixed an issue with cross-posting that might have affected your account. Let me know if the cross-posting still isn’t working.

1 Like

it did indeed - thankyou - including picking up a few recent ones that were clearly stuck somewhere.

thankyou - looks like Manton’s fix made it all ok again.

Bluesky cross posting is still broken, but in new ways.

Still no rich text, and for some reason this split into two posts, where the second one was just a link to the original note

Edit: the second post with just a link is from me experimenting with a separate cross posting. Rich text is still not working

I’m thinking the lack of links might be something about processing the XML feed, with some subtle difference compared to the default JSON feeds used in Micro.blog. I’m looking into this again.

For that extra blog post, though, are you sure that it was created by Micro.blog? I can’t see how that would happen, and when Micro.blog sends a copy to Bluesky it logs it under Account → View logs. I can see the log entry for that text version of the post but there’s not any additional attempt to send something to Bluesky.

Feed is https://bmannconsulting.com/journal.xml

As you can see, it’s cross posting to a Mastodon account and a Bluesky account.

You are in fact correct that the “link only” post was from a Fedica RSS cross post experiment.

But it means that the first post is still not doing rich text inline for Bluesky, even though it shows up fine on Microblog

I can make custom JSONFeeds rather than RSS it’s just very frustrating that this stopped working / doesn’t work as advertised / lightly documented at best.

Bluesky rich text inline works for “native” MicroBlog posts.

I’m going to make an attempt to rewrite my cross posting feeds as JSON Feeds and then give up.

For reference, $10/month for what is effectively unlimited custom feed cross posting I consider to be good value (reliable photo posting / hosting is the other Mb feature that is valuable to me).

I’m experimenting with Fedica and their feed-based cross posting is extremely basic.