Error sending post, Error uploading photo

I am using the latest version of on a Ventura OS 14" MacBook Pro.

For some reason, I am absolutely unable to use the microblog macos app for posting. When I tried posting a message with two photos, I got the first error message below. When I removed the photos and tried posting a simple “test message” post, I got the second error about missing a token.

When I check Preferences, I see my picture and I have my site selected as the destination.

Earlier this evening, I saw an error message on the site for my account in the Posts area that said to review the error logs. OK, tried looking at this long list of logs but had no idea what to look for. So I clicked the button to rebuild the site. That process seemed to finish successfully.

But when trying to post via the macos app, the two errors below still appeared.

I used MarsEdit to post to the blog and that seems to have worked. I see the post and the picture in the Posts area of the site, but I still haven’t seen the finished article appear yet on proper.



Sorry if these suggestions come off a bit like, “have you tried turning it on and off again?” :blush: Make sure the app is running the latest version, 3.0.3, and sign out and back in again. Does the problem persist after that?

To echo that, these errors do seem like a problem with not being signed in anymore. I’m sorry the error isn’t more helpful. Let us know if choosing File → Sign Out doesn’t fix it.

Thanks sod & manton - yes, signing out and back in solved the problem. I didn’t even know there was a sign out and in option.

Yes, I was using 3.0.3.

Did a test post just now and it worked fine.

To be fair, it’d been a while since I used the app, so perhaps this was expected? But I wasn’t expecting it and so spent about half an hour trying different scenarios to work around it and then document it.


That’s good to know. I’m sure we can improve this to better detect that situation and automatically sign you out if needed. I’ll work on that for a future version.