Error Building Site: Unmarshal YAML

@manton @sod I’m getting the following error while trying to build my site:


Hugo Error: Error building site: "/var/cache/snippets/cerebralrift_20fa74/content/2026/08/28/revisited-japanese-rivers.md:19:1": failed to unmarshal YAML: yaml: line 18: found character that cannot start any token

This isn’t any YAML in my post… Looks like maybe I was editing a bit too fast and got the editor into a confused state? I’ve tried updating the post, then doing a full rebuild of the site, but still seeing the same error.

I dug into this and it appears in that post (2026/08/28/revisited-japanese-rivers) there is a URL with “@System” in it. This is causing an issue. We can work around it, but I think a quicker fix will be to edit the img tag or whatever is referencing that.

Weird! That’s a URL for the image that was supposed to be converted on my end before the post was updated. Baffling how that got in there. Just remove the link and use:

https://cerebralrift.cc/uploads/2026/vlisa-japanese-rivers.webp

instead.

Just to clarify what happened… When I updated a post (a different one in this case) on my side the image was located along a path that starts with @System - the plugin grabs the image from that path, uploads it, then swaps in the uploaded path. I then have a YAML entry on my side that shows the mapping:

{"@System/_images/CerrebralRift/Vlisa-Japanese-Rivers.webp":"https://cerebralrift.cc/uploads/2026/vlisa-japanese-rivers.webp"}

The micro.blog side of things should never see that mapping.

Absolutely bizarre that this happened.