Domain is not working

I transferred my domain from WordPress to and I get a ERR_SSL_PROTOCOL_ERROR. It should route to which works if I go there.

So I just checked the help section and I never received anything from I need someone to assist me because my domain has not worked for almost a month and I am a paying member.

You should email support versus posting here.

I have emailed support three times with no response.

Unfortunately there’s some of that going on… non-replies… since the community manager left to pursue different things.

I just changed my account from to being just today. It didn’t work for the first two hours. MB didn’t see any of the changes. didn’t either. Then, I just deleted the A record (I use Netlify for DNS) and re-added the A record (with no other changes) and everything instantly started working.

Make sure that once you have the DNS side set, that you go to the Design section of MB’s side bar, and scroll down to the part where you enter your domain name too. You need to enter it there bare (e.g. not http://, not “www” etc.) and hopefully that will kick things into gear.

1 Like

Wow! I feel so dumb. I hadn’t checked the design section to enter the domain name. That fixed it. Weeks waiting on a response from them and you solved it! Thank you so much!

Glad you got it fixed! Very sorry for the missed reply.

So glad that helped. DNS stuff can be very frustrating. It took me nearly a week to set up iCloud Custom Domain email because Apple showed quotes in one value, and my DNS host didn’t care for quotes (other providers need the quotes for that value). Enjoy your blog!