Wordpress RSS feed stopped updating to Micro.blog

Not sure what the issue is here — I’ve made a couple posts to my Wordpress blog that haven’t been pulled in to my Micro.blog feed. The posts show up in the RSS feed itself. I’ve refreshed in settings. I also tried adding a JSON feed but no luck.

What should I check next?

Micro.blog: Micro.blog - @brentajones
RSS feed: https://blog.bjones.net/feed
(I have JSON Feed enabled, so you can add /json to the RSS feed for that, though Micro.blog is set to use the RSS feed for now)

I’m experimenting with a change on Micro.blog with how it processes very large RSS feeds, and this has broken some WordPress feeds. Your RSS feed is 400k and has 200+ posts in it. Until I can fix this, I’d suggest limiting your RSS feed in WordPress to only recent posts, like the latest 20 posts. (This limitation also doesn’t apply to JSON Feed if you want to switch to using that.)

Sorry about the trouble! I didn’t realize it was going to affect any WordPress feeds. Making your feed shorter will speed things up too, though.


No problem! Thanks for the solutions (and the rest of your work, of course). I’ll give them a try.

1 Like

Thanks. I imagine this is the same issue I’m experiencing? I can adjust the feed to recent posts. I wonder if pagination would help? It’s been on my TODO list for a while to implement that.

Limiting to 20 posts did get it unstuck, thankfully. Doubtful that I actually need more than that anyway.

1 Like

Great, glad that worked. Micro.blog doesn’t support RSS feed pagination, but it shouldn’t hurt anything either if you ever enable it.

Is this what would produce this error on my Squarespace RSS feed?

unknown error EOFError