BUG - heic converted to jpeg instead of jpg

When I upload a heic image via the web interface (i.e. https://micro.blog) it converts it into a .jpeg instead of a .jpg, and the usual action link to copy the html becomes unavailable.

Also, in the IOS app, it does it correctly, but the html doesn’t include the width, height, and alt options.

Huh, weird, I tried this just now using both the web interface and the iOS app and the HEIC file got converted into a JPEG (with .jpg as file extension) in both cases. If you’re up for it, can you share the file you’re having trouble with?

I do get the same behavior as you when copying the HTML for an image, the attributes are missing.

I should add that I’m on an iPad, using Safari.

Here’s a sample heic file that fails on me from the iOS camera roll, though not downloaded from Google Drive:

link on Google Drive

PS It may be because of iPadOS and iOS 16.5. Before I updated, uploading from the camera roll worked as expected, IIRC.

Thanks, I’m able to reproduce the problem now. It has nothing to do with the specific photo, but the fact that you’re uploading from the Photos app (camera roll) in Safari. The Photos app converts the HEIC to a JPEG behind the scenes, before uploading it to Micro.blog. It gives the new file the file extension .jpeg so you’re affected by this bug.

When that bug is resolved, you should be able to upload from the Photos app in Safari just fine. Workarounds until then:

  • Use the iOS app
  • Upload HEIC photos from the file browser instead (not the camera roll)

Those are workarounds, though a bit complicated, since the iOS app is flawed as well, and copying the photo to a file location involves extra steps for uploading to micro∙blog.

So, I hope it’s resolved soon.

This should be fixed now. Thanks!

Can confirm. It now works as expected. Thanks, @manton :+1:

Great! That fix is all @sod actually! :slightly_smiling_face:

1 Like