Custom Subdomain No Longer Working

Hi all!
I emailed about this last night, but thought I would post it here in case other people are having the same trouble. [Don’t feel pressured to double post team here and in email! I will post resolution/fix if required as you are busy peeps.]

I set up to act as my custom sub domain. Worked for about 15 minutes.

At the same time as this was happening, I was setting up my ‘self’ hosted WordPress page for with my provider Krystal.

Now, what I was hoping to happen is acts as my subdomain for the microblog and the root/primary domain is that little splash page currently up.

However, right now I can’t even ping Nor can I access at all (tho it does ping last I checked) Pretty sure it’s a DNS issue, but the thing is I had it working with microblog if only for a short instance. I’m hazarding a guess that something has gone screwy in setting up the root with WordPress? Honestly haven’t a clue but I am pretty sure it’s DNS related.

Any advice the community can give would be appreciated! My domain register is porkbun if that helps.

Edit: I failed to mention (my bad it was so early when I originally responded) that micro blogs team have indeed started investigating quickly even before this post and it appears the DNS settings are correct on their end but I have given them additional details so we shall see if we can solve this puzzle! The hosting provider on microblogs end had some downtime so perhaps that is causing a little delay? It’s just weird given the lack of ability to ping traceroute or DNS lookup on the custom domain.i shall update as we unravel this puzzle but thank you team for your effort so far!

Update for any who are interested! 90% sure I have targeted the issue. Although modifying the DNS records at the domain register worked initially, as the hosting company took the root address to set up a website, i had to start using their portal instead of porkbun. So I will let you all know in the morning if it works again!